Access Denied

dreamobjects

#1

Hi there.

I am using CyberDuck to upload files to DO, but everytime I try to go to a folder I see this:

AccessDenied

Bucket is public, but I don’t know abt the folder. On DH Panel I can change to public or private for buckets and files, not folders.
When I try to do on CyberDuck, it will try to do using amazon link (you see at footer). I changed connection to objects.dreamhost.com, it works fine, just to change folder ACL.
I tried using CrossFTP and it will always upload as private, tried changing and didnt work.

Anyone knows a better program to use?


#2

I’m a little confused, but what I think you’re saying is that you’re opening a browser window to bucket.objects.dreamhost.com/folder and you’re seeing the access denied error.

The interesting thing about folders in object storage is that they’re simulated. All of your files still live in a large bucket, but when a folder is uploaded, the object is named with the folder in the name. For example, Song.mp3 in the folder Music is actually named Music/Song.mp3 in your bucket.

We simulate the folder structure to make it easier to navigate. This also means you can’t go to bucket.objects.dreamhost.com/folder and see a listing of the files in the folder.


#3

So there is no private or public for folders? Only buckets and files?


#4

That’s correct, only buckets and files.


#5

I’m getting this same error. I’m using Interarchy, going to [bucket].dreamhost.com is giving me a 403.

GET / HTTP/1.1
Accept: /
Host: [bucket].objects.dreamhost.com
Authorization: AWS
Date: Tue, 26 Sep 2012 03:41:34 GMT
User-Agent: Interarchy/10.0.2

HTTP/1.1 403 Forbidden
Date: Wed, 26 Sep 2012 03:41:34 GMT
Server: Apache
Accept-Ranges: bytes
Content-Length: 78
Connection: close
Content-Type: application/xml

<?xml version="1.0" encoding="UTF-8"?>AccessDenied

#6

Someone was using Interarchy in the office and getting similar errors. We’re still trying to figure out why.