A PHP issue in Wordpress (Edited "Loop")

apps

#1

I’ve already posted this on Wordpress’ own forum regarding the issue. No response yet so I will give it a try here to see if the PHP gurus can explain the problem and how I might work around it:

I’m no professional developer, though I’m being asked to be one with an issue that I’m experiencing right now with a variant of the loop and a PHP issue.

Backstory: www.tampablab.com has been running as a local blog aggragator site since 2006 and is very popular. My partner just purchased the site from it’s developer and left me in charge of getting it ready to be re-launched. After getting some fo the plug-ins that make the site work sorted out, I had to import a variation of the Loop that was employed on this site:

’<?php while (have_posts()) : the_post(); ?>

<?php $TB_time_array[] = date('H:i:s'); $post = $wp_query->post; $show_post = true; $guid = get_post_meta($post->ID,'syndication_permalink',TRUE); if (array_key_exists($post->post_author, $listed_posts)) { $post_ids = explode("|", $listed_posts[$post->post_author]); for($i=0; $i < count($post_ids); $i++) { //echo ""; $listed_posts[$other_post->post_author] .= $other_guid."|"; } ?> <?php } ?> <?php } ?> <?php endwhile; ?>'

So I’ve saved thsi as the loop on the test blog that I am using while this is in beta and I’m getting a general PHP warning:

This (the error) is basically at the top of the loop variant. I should also note that this site has been running in ancient Wordpress 1.5.x and this new loop has been installed on Wordpress 2.3.3

I’m not quite sure about the conflict but I’d like to figure out how to preserve the loop while fixing the array issue. An help explaining the issue and how to resolve it appreciated


#2

Dang. I use WP, and I’ve messed with the internals just a wee bit, but not at the level you’re dealing with.

Honestly, enough changed from 1.5 to 2.0 that you’re going to need to dig a bit at the wordpress.org site. My guess is that you’re going to have to update that bit of code… or go back to WP 1.5…


#3

That’s probably the truth to it. I’m no PHP guru and I have messed witht eh loop before… but not to this degree. I know what the end result fo the actions are supposed to be but it’s the actual code and actions that I don’t get.

Noting I have yet to hear from anyone at Wordpress.org ont he problem, I would say they are as intimidated and dumbfounded as I am over this.