550 error


#1

I’m having trouble deleting a file. It prompts me with error 550. What do I do? Its preventing me from re-installing a forum in the same directory.


#2

For some reason it’s saying you dont’ have permission to delete that file. Are you loged into FTP with the user that is excuting CGI for the domain? not a user that has a directory re-map set up.

If not, see if you can change the permissions (CHMOD) the file to 777 read/write/excute for everybody and then delete it.

If that doesn’t work you shoudl telenet or ssh into your account and delete the file from there. search the K-base for help on using telnet/ssh if you need it. You’ll want to use "cd’ to move into a directory like this:
"cd domain.com/path/to/forum/"
You can use “ls” to list the files in the currnet directory and use “rm” to remove or delete the file. you’d type the command this way:
"rm file.name"
warning: be careful when using rm or "rm -r " as there is no undo or trash bin.

Or if you’re not comfortable using telnet/ssh and the other options above don’t work just contact support and ask them to help out.

-Matttail


#3

Yeh, Ive tried changing the CHMOD to 777 and it didn’t help. I also attempted to delted the files through ms-dos, command prompt, again without success. I’ll try these new commands again, but last time I tried with rmdir (or command similar to that) I got an error too, something like “the directory is not empty.” Is there no way I can just delete everything on my webspace and start a fresh as I have already asked for customer service and have gotten no reply for more than 24 hours.

P.S. Your help is very much apprciated


#4

Mhhh…
well to delete a directory you have to do recursively… so
rm directory/ -rf
-r recursively
-f force
also you can use rm -f archive.txt

Regards


#5

Oh ok, Ill try it right away. Thanks.

P.S. So is there no way of reseting my account completly?


#6

Ive tried the suggestion above.

I typed rm dir/ -rf

and I got a 550 error with the following message

Far out I dont care if its empty or not, just delete!


#7

try typing “rm -rf dir” see if that works

also, the only other way I would know to entirley clear out your domain would be to go to Domains > Mange and click the x across from your domain. that will clear out all E-mail address you’ve set up, all databases you’ve setup, and any settings associated with the domain. You’ll have to wait for the system to have time to entirley clear out everything and then you can add it back in, and wait for DH’s DNS servers to put the new entry back in. All in all, it would probably take less time to wait for support to help you out with simply clearing out the files.

Becuase support has ‘supper user’ access to their machines they will be able to delete the files regardless of who owns them or whatever.

-Matttail


#8

Thanks alot, yeh I think thats wise. I’ll just have to be patient and wait for support. If all else fails I’ll follow your instructions and reset my account :). Cheers.


#9

I have not installed the forum via the one click install… thinking on your problem… you can’t delete a dir, file if you are not the owner… (unix permision system)… I think… that probably some files are not from your user group, or thinking on other directions, had you any other users/groups on your account? maybe the files are from some other user of your own :smiley:

If all else fail… contact support :wink:

Regards


#10

Yeh true. I think I need the support people to clean things out for me. The problem is I set up the forum with the one click and then it must have added some files which only the admins of dreamhost have access too. I then uninstalled it wrongly (removed the SQL data base first) and now its corrupt. (I’ve tried setting up another database for a photogallery and its somehow not worked).

Yeh all in all, I’ve scrwed things up. I’m new to the buisness and I’d love to get a clean start on my website.

:slight_smile: thanks for all quick responses, so much faster then customer help

PS: also a question to one of the solutions provided, if I cancel the domain, will I still own the domain? If that makes sense.


#11

ya, you should. Dont’ cancel registration, just clear out the hosting side of the domain. I still think support will take care of this for you. They may be a bit bogged down riht now as there seems to be a few issues with the central database system and other people have mentioned long response times, but I believe they will get to you in due time.

-Matttail


#12

So could this downtime be the reason for my mySQL database not being setup quickly. I mean I never got the convermation email, and I couldnt log onto the data base. I just thought it was all part of the problem so I delted the database again.

Thanks agian for the help


#13

ya, it’s possible. I’m not sure what problems they’re haivng - but since the panel upgrade there’s been issues creating databases, people have been posting about not getting one-click install instructions, ect. and thoes services are all run by their central database setup that powers the panel.

Once you create a databae I’d give it 3 hours, if you still can’t log into phpmyadmin by that point, contact support.

-Matttail


#14

Ok, Ill do that. Yeh, I was just thinking all my problems were all related. So I thought one problem one solution. But if its the case that its only a dreamhost downtime then I could just rename the unusable dir and ignore it forever, haha.