500 server error using SMF search function



I have been running SMF (1.1 RC1) on my Web site for nearly a year.


Recently, one of our users discovered an error.
Whenever someone tries to search the forum using numbers and not letters, it returns a 500 Internal Server Error:

“The server encountered an internal error or misconfiguration and was unable to complete your request.”

I’ve checked the site’s error log and it gives this info:

Invalid query name 1
[Sat Sep 30 02:46:25 2006] [error] [client] Premature end of script headers: /dh/cgi-system/php.cgi

Numbers are an essential tool in distinguishing between various sets of Playmobil, since every set is given a unique 4 digit reference number.
So, for the forum users, being unable to search using numbers is quite a serious problem. They risk missing out on useful information or posting about a set which has already been discussed in another topic.

Any hints on how to fix this would be greatly appreciated!


In what server you are?

Im receiving the same error with Drupal


I’m hosted on larchmont.
You think this might be an error specific to that server?


I dont know, I just install my drupal in another host and works like a charm with same config so I dont know what is happening, the 500 Internal server error is appearing in this forums very often…

Im on Necco…


Have you guys compared which PHP versions are in use (both on the Dreamhost servers and on the other one you mentioned?) There are some subtle (and not-so-subtle) differences!


I appreciate that there are obviously differences between the two servers.

Since no-one seems to have any suggestions on how I might rectify the problem I’m having, I suppose the only option left to me is to add my request for help to the other 792 currently logged in DH’s customer support. :frowning:


I’m sorry if that seemed overly obvious, but it was a “real” suggestion designed to help you with your problem.

The reason I asked is that those differences can sometimes be a “really easy” thing to deal with - changing between php4 and php5 on Dreamhost is so easy, if it turns out that is the difference, your problem is solved.

It is also possible that running a phpinfo for the site that “works”, and those that are broken would point out what the differences are . If it is simply a default php setting that is causing the problem, that is easy enough to get around by using your own modified php.ini on Dreamhost.

I also assume you have tried to get some insight on this at the SMF forums (Iknow you can’t be excited about joining the DH support queue!).




I took a quick look over at SMF forums for you, and a couple of things come to mind:

  1. The 1.1 rc1 you are using is over a year old now, and there have been 2 major update (with several security issues addressed) since as well as enhanced compatibility between php versions.

  2. The latest update (1.1 RC3) reports, in addition to security fix(es), “tweaked” search functionality, and improved handling of number formats - maybe related to your problem

It may very well be that your problem is fixed with RC3, and from a security standpoint, the upgrade is one of those “must do” things anyway.

I suggest trying the upgrade as the first attempt at fixing the problem.



Thanks, rlparker. :slight_smile:
As a newbie to all this stuff, it helps to have things like this spelled out to me. :blush:

Here’s my phpinfo:


Perhaps musik would be kind enough to get the php info from the other site?

Yep! Tried there first. :wink:
I found a topic at the SMF forum started by another user (with a different webhost) who had the same problem about a year ago.
No response so far, unfortunately.



I was considering doing that pretty soon.

I admit I have been putting this off because I made a real lot of modifications to certain scripts (but not on the search page though! :stuck_out_tongue: ) and I’m not exactly looking forward to doing them all over again. :s

I was waiting for the next fully tested version of SMF to be released, rather than upgrading to another beta version, but maybe that’s too far off in the future.

I’ll definitely give it some serious thought. Thanks for the suggestions. :slight_smile:


No problem, Krystal :slight_smile:

Thanks for posting the phpinfo link. I took a look, and nothing looks obviously wrong. Have you tried setting your domain to run under PHP5, to see if that makes a difference?

It’s really easy to do from the Control Panel, and if it does not help, or “borks” something else, it is easy enough to set “back” to PHP4 using the same panel page.

Given the reputation of SMF, it may be that they are already coding to PHP5, and some small difference make be causing your bug.



I switched over to the higher PHP about 30 mins ago.

It hasn’t fixed the search problem, but I do notice that pages are loading considerably faster so perhaps it is more compatible with SMF.

Thanks again for the tips. :slight_smile: