500 Internal Server Error while installing WordPress

wordpress

#1

Hi,

I’ve been trying to do a One-Click-Install of Wordpress on a sub-domain. I have done this several times already on DH, so I thought it would be another speedy install, but I keep running into the same problem:

(1) I complete the One-Click-Install dialog on the administrative DH site, which tells me to check my email
(2) I get an email with the usual link to the /wp-admin/install.php file, fill everything out, and submit
(3) The website starts to load/send data, then eventually displays a message about a “500 Internal Server Error: The server encountered an internal error or misconfiguration and was unable to complete your request” with additional instructions to contact the webmaster and that a “404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

When I visit the site, I either get a flat-out database error or the WordPress site with a message saying it could not connect to the database. When I re-visit the install site, I get a message that indicates the database needs to be repaired. I’ve looked at the DB tables under phpMyAdmin, and with every repeated attempt it looks like only some of them are getting created (between 6 and 10 of the 13 I think WP eventually creates).

I found an article about how this may be a result of PHP timing out (http://wiki.dreamhost.com/Advanced_Troubleshooting_Techniques) and followed the instructions suggested there to increase max_execution_time, but to no avail. I updated all of the domains and subdomains to use PHP 5.3, but when I ssh into the server and run “php -v” I still get 5.2.17… so the PHP 5.3 “fix” to max_execution_time may not be working.

Either way, I’m stumped - I don’t know if there’s some other strange stuff going on but I’ve never had any of these sorts of problems with the other WP installs I’ve done.

Anyone have any ideas or suggestions?


#2

Have you opened a ticket with Dreamhost? The one-clicks should not need you to do anything special to get your files and database installed. Did the sub-domain propagate before you tried to use it?

Sounds like there is an issue on the DH side.


#3

Everything had propagated and I had not opened a ticket.

But when I tried these steps again this morning, it just worked instantly… so I guess it was an issue on the DH side that has been resolved. Or maybe just temporarily high load yesterday?

The help page I was referring to listed a location for error.log files that may give a clue as to what was happening - do you know if PHP timeouts would be listed in those error files?

Thanks!