500 internal server error when using BackupBuddy

wordpress

#1

I’ve been using BackupBuddy successfuly to migrate site versions from my production server to a subdomain on my account for client approval. Today I run into “500 Internal Server” errors when trying to run importbuddy.php. It doesn’t even get to step 1. (I check the subdomain and both the zipped backup file and importbuddy.php are there, but not the importbuddy.php folder that is created when it runs.) I’ve tried re-backing up and reuploading but it doesn’t help.

Any clues about what may be going wrong?

Algirdas


#2

500’s are the worst. You might get some info from the error log (~/logs/http/domain.tld/) but chances are it’ll be “end of script” type junk that is somewhat south of helpful. But take a quick look as a first step anyway in case they’re more informative! If this is code that “hasn’t been touched” and “worked last time” then one thing you might try is to issue a killall against the current PHP process via shell and try running the script again. It’s a bit “kick the tyre”-ish, but sometimes it pays off :slight_smile:


#3

I don’t know what that means or how to do it.

What I did was to delete the two files and the subdirectory, and then recreate the subdirectory, put the two files in again, and run it again.


#4

And… that worked?


#5

it’s possible you were hitting some php limits that are possible to edit with just a little tweaking. Please see the suggestions (specific to your setup) we’ve emailed your way if you’re still having trouble, and reply there with any questions!