500 error messages

wordpress

#1

I’ve been converting a 10-year old HTML site into a Wordpress site. There are over 800 pages of content, so it’s a massive job.

During the past few weeks as I’ve worked on it, I occasionally got a Internal Server Error. I wrote to Dreamhost about it, and they said that the problem is PHP memory, so I created a custom phrpc file as they suggested to increase the PHP memory to 128 MB.

But I still got the 500 error message. Yesterday I created an ini file, which I placed directly in Wordpress, giving Wordpress 128 MB of memory, and the site ran faster and smoother for a bit.

Today, I got several 500 error messages, and the site is super slow. And only me and a few people are accessing it right now. I’m so frustrated with this! I’d hoped to take the site live this week.

I’ve tried disabling the few plugins that I have, and that didn’t work.

Any suggestions? I’m at a loss. I looked and can’t even find any error logs. The newest error logs I found on the server are from 2011.

This is the site:
http://www.butterflywebgraphics.com/wordpress/

Thanks,
Bobette


#2

I ran your site through a speed test:

Your front page is taking over half a minute to load, but just about everything else is looking normal.

Do you mean an php.ini? If so, I don’t believe those will work when placed in your WordPress directory. (But apparently they will under certain circumstances.)

You can also add this to your .htaccess file:

or add this to your WordPress config.php file:

define('WP_MEMORY_LIMIT', '64M');

You might want to run a phpinfo() just to make sure your PHP memory did get boosted.


#3

Something is really wrong. I keep getting the 500 error message today and the site is loading at a snail’s pace.

Thanks for the link to the speed scan and the info about increasing the memory. I’ll try that.

I also found this scan, which was recommended on the Wordpress site:
sitecheck.sucuri.net

According to their scan, I have some critical website problems, and it suggested that I contact my webhost.

https://sitecheck.sucuri.net/results/www.butterflywebgraphics.com/wordpress/

So frustrating!


#4

Hi novelist99. Did you manage to solve the problem? Recently I configured my websites to use PHP 5.6 and I’ve noticed the same things as you have: my sites have been slowing down and I’ve been getting 500 error messages. My error log is also displaying “[Fri Nov 27 06:01:33 2015] [error] [client X.X.X.X] Premature end of script headers: php56.cgi, referer: WEBPAGE_URI”