404 -- but why?


#1

I created a new subfolder last night and dropped two large (27 & 22 Gb) movie files in it to transfer to someone else. Left it running overnight. My FTP client (Secure FTP 2.5) shows that they’re both there in the new folder. Unfortunately, when I call up the site/directory from another machine, it can’t be found. Cache is clear, I reloaded the page several times, but no luck. Any thoughts?

Scott


#2

Apache 1.3 doesn’t handle files larger than 4 GB. See what version your server is running:
curl -Is http://www.EXAMPLE.com |grep Server

Also, with files that large, it’s possible they didn’t finish uploading. Have you tried a different FTP client to verify the upload? Have you pointed a browser to just the directory to get a directory listing?

-Scott


#3

Additionally, some browsers will flake out with large filesizes.

If you can manipulate the files via shell, consider archiving into 2G chunks.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#4

Thanks – I ran that command and here’s what it spat out:

Server: Apache/2.2.11 (Unix) PHP/4.4.9 mod_ssl/2.2.11 OpenSSL/0.9.8c mod_fastcgi/2.4.6 Phusion_Passenger/2.0.6

I did try to point the browser directly to the folder, but no luck.

Oh, you know what? I’m an idiot. I had the folder created one level too high. It was in my root directory instead of the one named after my registered domain. palm to face

Thanks for the suggestions.


#5

We were saving the “You’re an idiot” suggestion for last, but you beat us to it. Glad to hear it works. So you can download those monster files in your browser successfully now?

-Scott