403 error changing from index.php to index.html


#1

Hi

I am updating a friends website and the initial page is changing from index.php to index.html. After uploading the new pages including the index.html I get the following error

You don’t have permission to access /index.html on this server.

Apache/2.4.7 (Ubuntu) Server

Can you please advise me on how I can change this.

Many thanks


#2

What are the permissions on the file index.html?


#3

the permssions are read and write unix equivalent 600. However I think it has something to do with the .ht file. I opened it up but it is just differnt numbers and letters. nothing about the index.php file. I never have a problem with index.html files when uploading via ftp


#4

The problem is 600. Apache can’t read the file, give it 644.

This doesn’t make sense at all, what are you trying to say here?


#5

I’m guessing the file path is set to be index.php. If this is the case I don’t know where to look to change it? any advise much appreciated!
[hr]
Sorry, I was comparing the .ht file to a different .htaccess file and it did not read like a .htaccess file. I am a newbie with servers and settings. I just do the front end stuff so apologies for not making sense. I will change the 600 thankyou
[hr]
that worked! many thanks for your speedy advise apologies again for my ‘assumptions’ on how things might or might not work. thank you