401 Error trying to access my new site


#1

I just recently signed up with Dreamhost. My DNS changes have taken effect, but when I try to access my new domain (http://jedfonner.com), I get an Authentication Required popup asking me for the username and password to access the site. And none of the username/password combos that I provided to Dreamhost work. Basically no one, including myself, can access my site.

I haven’t set up any .htaccess and in fact there’s nothing in my /home/jedfonner/jedfonner.com folder except index.html and index.php which both contain “hello world”. I did try using the “Goodies” to install Wordpress but have since uninstalled it.

What do I need to do to allow general viewing of my site?


#2

It sure does sound like there is a .htaccess file active for the domain. Are you there isn’t one in the jedfonner.com directory? Note that .htaccess is a ‘hidden’ file and will not be visible in your FTP client unless it has been configured to show hidden files.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#3

Yea, that’s what I thought as well. But I am ssh’ing into my site and correct me if I’m wrong but running ‘ls -al’ should display any hidden files. Yet I cannot find any .htaccess in either my /home/jedfonner or /home/jedfonner/jedfonner.com folders.

I’ve continued to play around, and this authentication problem exists for any subdomains I create and for any folders I create within the jedfonner.com directory. And again, I cannot find any .htaccess files.

It seems this problem was introduced by Dreamhost when my account was created. I hope they answer my support ticket soon.


#4

Yep, that should show any hidden files.

I tend to agree, it does sound like something is broken. I think lodging a support request, which you have already done, is your best option.

Unfortunately, DreamHost support seems to be under a huge load at the moment (464 open requests), so it may be a little while before they can get to your request.

Good luck.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#5

I had the exact same issue when I first signed up.
I filed 2 support tickets, and Sandon was able to figure out that I need to mod my web directory (and basically any files I intended for public access) to 0755.
That is to say, your public files need to be executable (chmod +x).

Since then, the 401 error went away and my site is up and running fine.