3 days and going: "Service Temporarily Unavailable"


[quote]Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.[/quote]

This is what I get when I load my site. Three days we are in a pointless discussion with the support with me telling them there is a problem and they telling me there is not.

From this taken just a few seconds ago web test it is clear the problem is Europe wide:

Is there a way to resolve the problem?
What can I do in this situation when I do not receive the service I have paid for?
The longer this downtime is going the more I think it was a mistake to use this host.
Please help, this is getting frustrating!


It would help to give the address of your site. If this is it: http://www.nivipa.com/ then it loads quickly for me just now.


Let me guess - you’re not located in Europe.


I’m in the US and I’m getting Service Temporarily Unavailable.

Looks like you have google page speed turned on tho, which adds another layer that could be problematic. Also if you’ve made changes to the site lately that may be an issue.

I’m not sure what you mean by “…when I do not receive the service I have paid for?” It’s possible there is a dreamhost issue, but more likely it’s a specific issue with your site, in which case it’s not dreamhosts job to troubleshoot.

If your site is wordpress based my guess would be that you have a combination of theme, plugins, and other settings (pagespeed being one) that are incompatible with each other. That would be up to you to diagnose and correct.


Even so, your site is up or else I wouldn’t be able to access it. Just cleared cache and relaunched a browser and it load quickly again. Can’t be a server issue; more likely a net routing hang-up.


I understand that the blame game can go on forever - this is not my understanding of quality service. Being told “we have no problem so there is no problem” or “we don’t have a problem so this is your problem” is counterproductive. I can see there is a routing problem from the web test - it clearly shows where the page loads fine and where it does not. I have no idea how Dreamhost provides the hosting but the fact that the error is reported as a server problem also deserves attention. All pagespeed errors I have seen so far clearly reveal themselves as pagespeed errors. Pagespeed has been turned off according to what Google suggests - by disabling rewriters. If we assume it’s a routing problem and routing is beyond Dreamhost diagnostic - who is responsible for it? If some people don’t have access to a site and some do, and this goes on for days - what is the way out of this?


Dig in an figure out where the conflict is. No one can do this for you. If dreamhost reports the server is working correctly then you have something incompatible. Sitting here and claiming the blame game isn’t going to get you anywhere… what will get you somewhere is diving in and finding the problem.

FWIW the page I loaded with the error was served up via google pagespeed, start by turning that off.

If you running wordpress you will do much better getting advice from this forum if you tell us about your site… i.e. where did your theme come from? exactly what plugins are enabled. Many people here know what causes problems when mixed together.


LakeRat - how did you know the error page was served via google pagespeed?
If you can diagnose that the problem could be pagespeed - why does not Dreamhost support do the same?
As I said - rewriters have been disabled, changing DNS settings would be a last resort.
It is a wordpress site, the plugins and the theme have been working ok - if there was a problem with them causing a server problem - wouldn’t Dreamhost support notice and report back to me on my ticket?


By viewing page source.

and not necessarily… read the forum and you will find many instances of plugin a, b, and c work fine until d is added, then b starts eat RAM and processor time until procwatch kills something to protect your neighbor. Or plugin G is great, but not with pagespeed enabled, etc etc. Talk about that kind of thing in this forum and you will get feedback about what works well and what doesn’t, or suggestions to something you missed that performs better.

Think of an office building. You rent space there, if the lights go off, or the ceiling leaks then you call the landlord. On the other hand the landlord doesn’t tell you how to run your business or what you should or should not do within your business… after all you paid your rent and the lights and heat work, why would they tell you how to do your stuff.

Same with dreamhost, you rent space, they keep the server online, what you do in your space is your business.


A good landlord would do everything to keep a good tenant and solve a problem like inaccessible premises. I have replaced the index.php with an intex.html “maintenance” - I think this should be enough to test if the problem is with worpress or not. All cache is emptied, flushed and purged. Absolutely no change - the error remains. Any ideas?
Hmm - after half an hour the error on the index.html is gone. It remains on the php. Ok - so let’s see what might have messed up wordpress - the theme is minimatica, active plugins:
Clean and Simple Contact Form
P3 (Plugin Performance Profiler)
Revision Control
Transposh Translation Filter
W3 Total Cache
WordPress SEO
WP Smush.it
All updated. Some of them very recently - is there a log that logs the time of plugin updates?


All plugins have been disabled - the error is still present.


For the record - Google Pagespeed service (not the beta on the Dreamhost CP) was the cause of the error - once it was off the CNAME - the error disappeared. Google should work on clearly labeling their own errors, while Dreamhost support should be aware of all that and this should be on the top of their error/complaint diagnostic.


Hah, Google labeling their own errors…

I’ve been banging my head on the wall with them recently, arguing that Pagespeed isn’t doing things right… and giving me directions on how to do it in Pagespeed.

Thanks for letting us know, though!


Thank you, Optimist. I have had the 503 error for a few days as well, although not all the time. It appeared after the PHP upgrade, but not immediately after. At times my front page (in plain html) appeared, but the Wordpress sites did not. At times the front page appeared when using one ISP and none of them when using another, which strongly implied that it was not quite a server issue as the error implied. I found no system in it though.

I have now turned off the beta Pagespeed on my domain - to the best of my knowledge that is the only Pagespeed involved - and after a quarter or so, everything was running smoothly. It still is, the next day. So crossing fingers that this is the only reason.