2532 Gigs

apps

#1

Hi. I’ve been trying to install the application 2532|Gigs on my server but for some reason it doesn’t seem to be working.

The error I keep getting is

[quote]Warning: mysql_connect() [function.mysql-connect]: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /home/.saucey/damnably/damnably.com/gigs/install/install.php on line 268

Warning: mysql_select_db() [function.mysql-select-db]: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /home/.saucey/damnably/damnably.com/gigs/install/install.php on line 277

Warning: mysql_select_db() [function.mysql-select-db]: A link to the server could not be established in /home/.saucey/damnably/damnably.com/gigs/install/install.php on line 277
Settings have been entered.[/quote]

I have made sure the host name isn’t on localhost but my mysql host and also double checked all the database, password and username details.

Any help is fully appreciated.


#2

OK so you are saying you can access the database by browsing to http://hostname/ and being prompted for the username and password and successfully getting into PHPMyAdmin?

If you are then the problem is most likely with either how you are specifying the details or how the script is trying to use them.

I’ve looked at the source code. First it gets the database details from the form data POST’ed to the script. Then it writes these to disk in the settings file. Then it attempts to use them to connect to the database.

The settings file is apparently named gig_settings.inc.php - given the steps above, you should check the contents of this file and make sure the database details match exactly what you use to get into PHPMyAdmin. Please let me know if they are blank or not the same.

:cool: openvein.org -//- One-time [color=#6600CC]$50.00 discount[/color] on [color=#0000CC]DreamHost[/color] plans: Use ATROPOS7


#3

yeah, I could log into phpmyadmin quite easily. I think I’ve figured it all out though, it looks like the details I was putting in wasn’t writing themselves to the gig_settings.inc.php for some reason, so I manually put them in and it worked. I’ve trippled checked the chmod’ing and that all seems to be fine. Thanks for the help.