10 hour delays on emails with spam filtering


#1

For the past week or so, I’ve been seeing terrible delays with a domain that has spam filtering enabled. Oddly, these delays happen only for emails that come from a certain domain - other emails are delivered within 1-5 minutes.

Here’s an example set of headers - note that there are timezone changes (some are using PDT -0700 and others are using GMT +0000). Can anyone read this and determine where the delay is happening?

(from and to addresses replaced with ‘alice’ and ‘bob’ for privacy)

Return-Path: <alice@cougars.csusm.edu> X-Original-To: bob@bob.com Delivered-To: bob--bob.com@homiemail-mx27.g.dreamhost.com Received: from vade-backend7.dreamhost.com (unknown [66.33.205.213]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by homiemail-mx27.g.dreamhost.com (Postfix) with ESMTPS id ADCE320049E21 for <bob@bob.com>; Fri, 30 Sep 2016 00:11:28 -0700 (PDT) Received: from NAM01-SN1-obe.outbound.protection.outlook.com (mail-sn1nam01on0082.outbound.protection.outlook.com [104.47.32.82]) by vade-backend7.dreamhost.com (Postfix) with ESMTPS id ACB574000785A for <bob@bob.com>; Fri, 30 Sep 2016 00:11:27 -0700 (PDT) Authentication-Results: vade-backend7.dreamhost.com; dkim=fail reason="verification failed; unprotected key" header.d=cougars.csusm.edu header.i=@cougars.csusm.edu header.b=Em+NJz3u; dkim-adsp=none (unprotected policy); dkim-atps=neutral Received: from DM2PR0501CA0037.namprd05.prod.outlook.com (10.162.29.175) by BLUPR05MB420.namprd05.prod.outlook.com (10.141.27.26) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P384) id 15.1.649.6; Thu, 29 Sep 2016 20:36:50 +0000 Received: from BL2FFO11FD014.protection.gbl (2a01:111:f400:7c09::149) by DM2PR0501CA0037.outlook.office365.com (2a01:111:e400:5148::47) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P384) id 15.1.649.6 via Frontend Transport; Thu, 29 Sep 2016 20:36:48 +0000


#2

Hi soylentgreen,

Thank you for contacting us for support. If you have not already done so please contact our support team here https://panel.dreamhost.com/index.cgi?tree=support.msg& with the details of the email issue and they will investigate further,

Thanks!
Matt C