1-click wordpress installation has a bug

wordpress

#1

Ok, this is really annoying. I installed wordpress, went and configured it, and when i start browsing, i notice all the links are broken.

I went on the dashboard and checked the settings i defined for the permalinks. I put something like this:

http://example.com/blog/%postname%

I updated it a couple of times but it allwas goes back to

/http:/example.com/blog/%postname%

like… wtf… this basically results in an unusable blog as all the links get broken.

Is this a known bug or something?


#2

Something is wrong with wordpress itself. You may try to find solution in wordpress’s official forum.

Meanwhile, you can try to open its database and manually update this variable in the table. It will take some time to find it :slight_smile:

Good luck

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here


#3

It is for sure not a problem with wordpress. I tried to fix it manually and i ended up in a world o redirection loops and broken urls.

I then deleted the installation and installed it manually. Now there’s no such problem.
This was really annoying. The 1-click install was supposed to make things easier, what’s the point of it if its poorly set up? I ended up wasting unnecessary time.
So here’s an advice for the wise: don’t get fouled, screw DreamHost 1 click installs, 5 minutes extra spent on a manual installation are absolutely worth.

Anyway, thank ou patrck for the quick reply.


#4

Just put /%postname%/ – not the whole URL.


:stuck_out_tongue: Maximum savings promo code: MaxSavingsAtDH


#5

I’ve tried that before, it led to broken weird links.


#6

It’s the correct format, though… so it would probably still be a good starting point in narrowing down the problem.

Also, you have:

If you only have 1 slash after the http: somewhere, that might throw something off as well.

Anyway, I always use /%postname%/ as the custom structure and never have any problems with it.


:stuck_out_tongue: Maximum savings promo code: MaxSavingsAtDH