1-click-install (WP) broke my site

wordpress

#1

This is what I sent to support:

I just upgraded Wordpress via 1-click-install, now my site is
broken:

(1) All static pages (=Wordpress “pages”) are gone, basically my
entire site!!

(2) And I can’t switch back as there is no .old directory. The only
ones I could find are old and empty.

Please help!!

DETAILS:

  • Upgrade from 2.0.4 to 2.1.2
  • Footer in dashboard still shows “2.0.4”.
  • I was asked 2 times after running the upgrade-script to upgrade the
    DB, by the WP-Backend.

My guess: Upgrade process got stuck.

They haven’t replied yet.

I looked for backup folders various times and could only find three wp.old (.1, .2) folders with timestamps from 2006 and partly empty - certainly not current backup folders.

What can I do?


#2

Further details:

  • All static pages and image uploads (!) have been converted to blog posts.

  • The theme has been replaced by the default theme (which I could undo).

  • From time to time when using the WP-backend I’m being asked to upgrade my database. The upgrade-script finishes with success each time.


#3

One of the first things you should try, is to rebuild permalinks in your backend, as that could fi many things with your “pages” links. Outside of that, and hopefully successfully completing the upgrade script, is all I can suggest until suppoprt gets back to you.

–rlparker


#4

How does one rebuild permalinks?


#5

Site Admin --> Options–> Permalinks --> (any changes as necessary) -->Update Permalink Structure

–rlparker


#6

Tried, it didn’t change anything. All my pages are still only acessible as posts. Page-URLs give 404s. See my site at http://www.helge.at


#7

Well, if you don’t have a vaild/functioning “.old” directory to revert your site to it’s condition before the borked upgrade, and absent any response from DH support, the only other things I could suggest are:

  1. Export your existing data from the database (assuming that the upgrade.php script did successfully run) and then re-install WP 2.1.2 from “scratch” and re-import the database. This should solve any “partially updated” code issues that may have been involved in the “one-click” upgrade.

  2. Investigate returning your site to its “pre-upgrade” condition via the .snapshots directories and “recovering” your database from a time before you ran the upgrade script, then trying the upgrade again (I would do it manually, myself). You might want to see if support can make a “pre-updated” copy of your database available to you.

I’d also like to know what, if anything, you have heard from support regarding this.

–rlparker


#8

Hi rlparker,

I went for #1 an re-installed WP manually. Now it seems to be working fine, yet my pages coninue missing.

Also, I tried to re-create my pages with copy&paste content. This is what happened:

  • Before: 404.
  • Now: Showing the correct but displaying the blog-index instead of the page content.

What can I try next?

Support has finally answered: " Hmm, I tested your site, and it seems to be working, are you still having problems?"

What can I say… Not very helpful.


#9

Hi muesliq2:

Looking at your site, I am still getting 404’s for the “more” (sitemap page) and WAN list, and “Contacts” shows the blog index (I’m guessing that is the only one you have actually tried to “rebuild”).

My suspicion is that the problem is .htaccess related. Do you have a copy of your “old” (working) .htaccess that you can compare to your current .htaccess files? Additionally, the interaction between permalinks and .htaccess is ususally the culprit in such situations.

This is not my area of expertise with WordPress, so I’m at a bit of a loss to know what to suggest next other than that.

You might find more useful help on your particular issue at wordpress.org (in the forums and the codex), for example, this thread and others seem to be related to your problem.

I would, since the re-install, again update my permalinks, and inspect the .htaccess file for potential issues - and then explore the WordPress support forums a bit for some more insight if that doesn’t work.

Another think I would do is to create and entirely new “page”, as a test, and see if the problem exhibits itself there also.

I agree that is not a very helpful response, and (assuming that you accurately described the problem) would make me think the support person either did not carefully read my description of the issue or did not actually “test” the site. I’ would respond back to that support ticket with additional information - I think you deserve a beter answer than that one.

–Good luck, and make sure and let us know what you find the problem to be. :wink:

–rlparker


#10

Hi rlparker,

you’re guessing right, the contact-page is the one i have tried to rebuild. I have deleted the previously created copy and gone into the database and set post_type from ‘post’ to ‘page’. Yet as you see the content of the page still doesn’t show up.

I doubt that it has to do with .htaccess as it hasn’t been changed during upgrade, and neither has the permalink structure. I have double-checked. I also pressed “update permalink structure”, no help.

I think my database got messed up during upgrade. I have asked support for a pre-upgrade-copy.

Regarding WP-codex: A moderator already gave up on my issue there…: http://wordpress.org/support/topic/112183