DreamHost Forum
change max upload size problem - Printable Version

+- DreamHost Forum (https://discussion.dreamhost.com)
+-- Forum: Customer Discussion (/forum-1.html)
+--- Forum: Beginner's Forum (/forum-5.html)
+--- Thread: change max upload size problem (/thread-65684.html)

Pages: 1 2 3 4 5 6 7


change max upload size problem - windtown - 01-03-2007 10:40 PM

yes. it contains 2 files, php.cgi and php.ini.
i also added the code into my .htaccess file.
but my php forum list out my max upload size and post max size is same as the original i not changed.


change max upload size problem - Raz2133 - 01-03-2007 10:54 PM

Quote:i also added the code into my .htaccess file.
I am assuming that this fixed your server errors. Smile

Quote:my php forum list out my max upload size and post max size is same as the original i not changed.
You need to determine if your new php.ini settings are actually being used. Create a file called phpinfo.php containing the line below and place it somewhere in your domains web directory.

<?php phpinfo(); ?>

Now browse to this file with your browser, in the information displayed you can confirm whether you new install is actually being used and whether the post_max_size and upload_max_filesize settings have been changed.

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)


change max upload size problem - windtown - 01-03-2007 11:19 PM

it list out my upload_max_filesize = 7M, post_max_size = 8M
it's not changed. but i already executed it properly. don't have any problem, why it not changed?


change max upload size problem - Raz2133 - 01-03-2007 11:26 PM

Quote:it list out my upload_max_filesize = 7M, post_max_size = 8M
OK, this suggests that either your new install is not being used, or the settings in your new php.ini file are not correct.

When you browse to the phpinfo.php file you created earlier, what is being shown for 'Configuration File (php.ini) Path' ?

Also, please post the contents of your .htaccess file.

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)


change max upload size problem - windtown - 01-03-2007 11:30 PM

Configuration File (php.ini) Path = /etc/php5/cgi/php.ini

the content of the .htaccess:
Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi


change max upload size problem - Raz2133 - 01-03-2007 11:38 PM

Quote:Configuration File (php.ini) Path = /etc/php5/cgi/php.ini
OK, this tells us that your new php.ini is NOT being used.

Quote:Options ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi
This looks correct.

Is the .htaccess file placed in the root of the web directory for your domain ( example: abc.com/.htaccess ) ?

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)


change max upload size problem - windtown - 01-03-2007 11:41 PM

In my website root


change max upload size problem - rlparker - 01-03-2007 11:44 PM

It is important that you put the correct .htaccess file Mark described in his earlier post, and described in the wiki, in the proper directory.

If you have not done this (if the file the .htaccess file is in the wrong directory), if there is a mistake in either the php-update.sh script, a mistake in your php.ini file that is *now* in your cgi-bin directory, or a mistake in the .htaccess file itself, it will not work.

It is important you run the phpinfo() program Mark described. You should also check your error log (found in /home/yourusername/logs/yourdomain.tld directory) to see the details of the 500 Internal Server Error.

Your other described error messages indicate there may be a problem with your edited script file. Make sure you are editing in a pure ASCII mode editor, and that you are saving the file with *nix style line endings (see google for help with that if needed).

Again: If you follow the steps exactly as described, you have placed the files in the appropriate directories, you have executed the php-update.sh script successfully, you now have php.cgi and php.ini in the cgi-bin directory, *AND* have the correctly modified .htaccess file in the "base" web-accessible directory of your domain (abc.com?), it *will* work and running phpinfo.php (as described by Mark) will reflect the new values.

--rlparker


change max upload size problem - windtown - 01-03-2007 11:46 PM

500 Internal Server Error. <-- this problem is solved.
Only the post_max_filesize and upload_max_filesize is not changed i list out in last post.


change max upload size problem - Raz2133 - 01-03-2007 11:51 PM

Quote:In my website root
Just confirming, the .htaccess file should be in the root of your domains web directory, that is it should be in the directory named abc.com/, NOT in the root of your home directory.

To recap;

You should have a directory like abc.com/cgi-bin/ , this directory should contain the files php.cgi and php.ini

Your .htaccess should be in your web directory like so, abc.com/.htaccess , this file should contain the following;

Options ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi


If all this is true, then the new install (and php.ini settings) *should* be working.

Please look over the above carefully and confirm that this is how things are in your domains web directory.

Mark

--
Save $50 on DreamHost plans using PRICESLASH promo code (Click for DreamHost promo code details)