DreamHost Forum
change max upload size problem - Printable Version

+- DreamHost Forum (https://discussion.dreamhost.com)
+-- Forum: Customer Discussion (/forum-1.html)
+--- Forum: Beginner's Forum (/forum-5.html)
+--- Thread: change max upload size problem (/thread-65684.html)

Pages: 1 2 3 4 5 6 7


change max upload size problem - windtown - 01-02-2007 05:09 AM

I also follow this page's steps:
http://www.phileplanet.com/archives/2006/08/how-to-setup-ssh-on-windows-xp/
it list out the problem i asked just now.


change max upload size problem - rlparker - 01-02-2007 05:21 AM

If you followed the instructions on the page that you indicated in your last post, you will need to *create* the directory (folder) named .ssh in your "user" base directory on dreamhost (/home/yourusername/).

Again, you do not have to follow all of these steps to connect successfully; you can simply run putty from windows XP, enter yourdomain.com for the "host name", make sure port 22 is indicated, select the "SSH" radio button, and click "Open" at the bottom of the Putty initial screen.

PuTTY will then connect with the shell at Dreamhost and ask you for your username/password interactively. Enter those, and you should be connected.

--rlparker


change max upload size problem - windtown - 01-02-2007 05:25 AM

i connected with the dreamhost using ssh2. while i connected, the command line closed automatically.


change max upload size problem - rlparker - 01-02-2007 05:28 AM

Do you mean the *Windows* command line?

--rlparker


change max upload size problem - windtown - 01-02-2007 05:30 AM

my meaning is the putty connection to ftp ssh2 server


change max upload size problem - rlparker - 01-02-2007 05:33 AM

I see, Have you *confirmed* that the user name you are trying to use to connect *is* a "shell" user in the Dreamhost Control Panel?

--rlparker


change max upload size problem - windtown - 01-02-2007 05:34 AM

Welcome to hansens.dreamhost.com

Any malicious and/or unauthorized activity is strictly forbidden.
All activity may be logged by DreamHost Web Hosting.

This account allows only ftp connections.

what thats mean? password wrong? login name wrong?


change max upload size problem - rlparker - 01-02-2007 05:53 AM

Quote:This account allows only ftp connections...what thats mean? password wrong? login name wrong?
*Now* it is making sense! You are connecting directly to the Dreamhost server rather than using your domain name, and the user you are using does not appear to be authorized shell access.

I have mentioned this several times; you *must* have your user enabled for shell access to connect via ssh (or telnet). If your user is an FTP only user, that will cause you connection to be refused if you try to connect via ssh, ssh2, or telnet even if you use the correct username and password for your (ftp) user.

Goto the Control Panel, Manage users screen and look at the user name you are using to login. Under the "TYPE" column, make sure that user is indicated as being a "shell" user, not an "ftp" user.

If the user is not indicated as being a "shell" user, click the "edit" link to the right of the "Disk Storage" column for the user name, and select the check box for "shell" in the next screen, and save the settings.

After a short wait, the user's status will be changed and you will be able to login via ssh.

--rlparker


change max upload size problem - windtown - 01-02-2007 06:13 AM

how to change max upload size using putty?
i'm new to putty?
while i connected, it connected to my ftp serveR?


change max upload size problem - rlparker - 01-02-2007 06:15 AM

DO YOU HAVE A USER CONFIGURED AS A SHELL USER?

--rlparker